Welcome to AutoBoardz.com!
FAQFAQ    SearchSearch      ProfileProfile    Private MessagesPrivate Messages   Log inLog in

HELLO ALL AND I NEED SOME SUGGESTIONS

 
   AutoBoardz (Home) -> Volkswagen RSS
Next:  2003 durango 4.7 a/c problem  
Author Message
CHEN




Joined: Jul 14, 2010
Posts: 2



(Msg. 1) Posted: Wed Jul 14, 2010 8:42 am
Post subject: HELLO ALL AND I NEED SOME SUGGESTIONS

[/b] Very Happy [b]HELLO everyone.
I am new here , but I really need your help or advice , please!
I want to buy the AUTO video player gps navigationsystem for my car and I saw one on http://www.cargpsvideo.com/golf-dvd-navi_c803 .It is cheap , only a little more than 200$ . So I think it has high cost performance . But I still need your advice . Please provide some suggestions for reference.Thanks!
Razz Exclamation Question

 >> Stay informed about: HELLO ALL AND I NEED SOME SUGGESTIONS 
Back to top
Login to vote
Display posts from previous:   
Related Topics:
Alternator question - Hi I have a 1984 VW rabbit gti. The brushes are worn on my alternators voltage regulator. Can just the brushes be replaced? IF not I looked into getting a new regulator as they are only about $25. However I noticed that there are two sizes a 28 mm or...

92 Cabriolet heater core, it's supposed to be easy!?!? - I could really use some insight into this by someone who's done it. The heater core is accessible through a slot in the side of the heater box on the drivers side but it can only come out 4 inches before it runs into the pedal assemblies. I figured....

wishbone has some play in it.... - hi all, Can anyone give me some advice please........ I recently had my anti-roll bar brushes replaced and since then my Golf (4Motion if this makes any difference!) has been pulling to the left. Today I had it checked out and they think the cause is....

Your starter for 10 - What is the difference between the TSI 140 and the TSI 170 ie how is the extra 30PS obtained, engine mapping or higher boost levels?

Automatic Vanagon Must Shift to Start - Well, my 91 Automatic Vanagon has a starting problem. About 65% of the time (and growing) I go to start her up there is no noise or cranking or anything from the engine area. The electric works fine at this time. If I shift it into N and then try to..
   AutoBoardz (Home) -> Volkswagen All times are: Pacific Time (US & Canada)
Page 1 of 1

 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



[ Contact us | Terms of Service/Privacy Policy ]